読者です 読者をやめる 読者になる 読者になる

Metonymical Deflection

ゆるく日々のコト・たまにITインフラ

Bonding Interface設定

Ciscoライクに言うとEtherChannelになります。
一般的にはLACPとか802.3ad*1で良いと思います。


2つ以上の物理NICを論理的に1つのNICとなるように設定する。
CiscoのConfigライクに書くならば、こういうこと↓ができるってこと。

vlan 100
!
interface Port-channel1
 switchport access vlan 100
 switchport mode access
!
interface FastEthernet0/1
 switchport access vlan 100
 switchport mode access
 channel-group 1 mode on
!
interface FastEthernet0/2
 switchport access vlan 100
 switchport mode access
 channel-group 1 mode on
!
interface Vlan100
 ip address 192.168.100.1 255.255.255.0


それでは行ってみよう。

1.Bonding Interfaceの有効化

以下のファイルを開く。

vi /etc/modprobe.conf
以下の設定を追記することで、Bonding Interfaceを有効化する。

alias bond0 bonding
options bonding mode=0 miimon=200

Optionのモード設定などは以下のURLを参照。
http://www.jp.redhat.com/magazine/jp/200904/rhel.html

2.Bonding Interfaceの設定ファイル作成

以下のファイルを開く。

vi /etc/sysconfig/network-scripts/ifcfg-bond0

DEVICE=bond0
BOOTPROTO=static
ONBOOT=yes
IPADDR=192.168.100.10
NETMASK=255.255.255.0
NETWORK=192.168.100.0
BROADCAST=192.168.100.255

以下2つがポイント。
DEVICE=bond0を設定している点
BOOTPROTO=staticを設定している点

3.Bonding Interfaceに物理NICを追加

ここでは例として、eth1とeth2でBondingする設定を記載します。


eth1のファイルを開く。

vi /etc/sysconfig/network-scripts/ifcfg-eth1

# Intel Corporation 82572EI Gigabit Ethernet Controller (Copper)
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
HWADDR=00:1b:21:2a:5f:e9
MASTER=bond0
SLAVE=yes


eth2のファイルを開く。

vi /etc/sysconfig/network-scripts/ifcfg-eth2

# Intel Corporation 82572EI Gigabit Ethernet Controller (Copper)
DEVICE=eth2
ONBOOT=yes
BOOTPROTO=none
HWADDR=00:1b:21:2a:5e:67
MASTER=bond0
SLAVE=yes

ポイントは以下3つ
BOOTPROTO=noneを設定している点
MASTER=bond0を設定している点
SLAVE=yesを設定している点


4.netwrokサービスのリスタート

ifupを実施すればOKですが
「きちんとBondingされたことを確認する」という観点で言えば、
netwrokサービスをリスタートしましょう。

以下のコマンドにてリスタート。

/etc/rc.d/init.d/network restart

インターフェース eth0 を終了中:                            [  OK  ]
インターフェース eth1 を終了中:                            [  OK  ]
インターフェース eth2 を終了中:                            [  OK  ]
ループバックインターフェースを終了中                       [  OK  ]
ループバックインターフェイスを呼び込み中                   [  OK  ]
インターフェース bond0 を活性化中:                         [  OK  ]
インターフェース eth0 を活性化中:                          [  OK  ]

上記のように終了中は、eth1とeth2が表示されますが、
活性化中は、bond0のみになっていればOKかと。*2

以上です。

*1:厳密には設定可能なモードのうちの1つが該当する

*2:上記の出力ではeth0経由でsshにてログインし、eth1とeth2の設定を実施しています。物理NICが2つしか無い場合には、シリアルコンソール接続設定を実施しておけばOKです。